Skip to content

Commit bfcefb7

Browse files
committed
Add Blink package
Closes #605
1 parent 6d537c6 commit bfcefb7

File tree

1 file changed

+139
-0
lines changed

1 file changed

+139
-0
lines changed

pkgs/by-name/blink/package.nix

+139
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,139 @@
1+
{ lib
2+
, fetchFromGitHub
3+
4+
, python3Packages
5+
, x11vnc
6+
, libvncserver
7+
, pjsip
8+
}:
9+
10+
let
11+
# AG Projects dependencies required for Blink
12+
python3-application = python3Packages.buildPythonApplication rec {
13+
pname = "python3-application";
14+
version = "3.0.7";
15+
pyproject = true;
16+
17+
src = fetchFromGitHub {
18+
owner = "AGProjects";
19+
repo = "python3-application";
20+
rev = "refs/tags/release-${version}";
21+
hash = "sha256-gGq1V+4GrjUgp6XteWAko4YRZuCWGArvImp8isUOoMU=";
22+
};
23+
24+
build-system = with python3Packages; [
25+
setuptools
26+
];
27+
28+
dependencies = with python3Packages; [
29+
zope-interface
30+
];
31+
32+
pythonImportsCheck = [ "application" ];
33+
};
34+
35+
python3-sipsimple = python3Packages.buildPythonApplication rec {
36+
pname = "python3-sipsimple";
37+
version = "5.3.3";
38+
pyproject = true;
39+
40+
src = fetchFromGitHub {
41+
owner = "AGProjects";
42+
repo = "python3-sipsimple";
43+
rev = "refs/tags/${version}";
44+
hash = "sha256-SiJo6YoYy4OiVVVKhfy0U1z4iz5aYPHu2P6JuJjXyEI=";
45+
};
46+
47+
build-system = with python3Packages; [
48+
cython_0
49+
setuptools
50+
];
51+
52+
dependencies = with python3Packages; [
53+
];
54+
55+
buildInputs = [
56+
pjsip
57+
];
58+
};
59+
60+
python3-otr = python3Packages.buildPythonApplication rec {
61+
pname = "python3-otr";
62+
version = "2.0.2";
63+
pyproject = true;
64+
65+
src = fetchFromGitHub {
66+
owner = "AGProjects";
67+
repo = "python3-otr";
68+
rev = "refs/tags/${version}";
69+
hash = "sha256-Zt5nCkt9qdw5MJWrLJoMpi3ZhlCBDPAiAvoT1rBnWo0=";
70+
};
71+
72+
build-system = with python3Packages; [
73+
setuptools
74+
];
75+
76+
dependencies = with python3Packages; [
77+
cryptography
78+
gmpy2
79+
python3-application
80+
zope-interface
81+
];
82+
83+
# FIXME:
84+
# nativeCheckInputs = with python3Packages; [
85+
# unittestCheckHook
86+
# ];
87+
88+
pythonImportsCheck = [ "otr" ];
89+
};
90+
91+
in
92+
python3Packages.buildPythonApplication rec {
93+
pname = "blink-qt";
94+
version = "6.0.4";
95+
pyproject = true;
96+
97+
src = fetchFromGitHub {
98+
owner = "AGProjects";
99+
repo = "blink-qt";
100+
rev = "refs/tags/${version}";
101+
hash = "sha256-QESg9yo5oddYqSKuFLSMI2Oju3FCq97+j0uJDK85Yy8=";
102+
};
103+
104+
# TODO: try to set language_level instead of using cython_0
105+
# postPatch = ''
106+
# substituteInPlace "setup.py" \
107+
# --replace-fail \
108+
# 'libraries=["vncclient"])]),' \
109+
# 'libraries=["vncclient"])], language_level = "2"),'
110+
# '';
111+
112+
build-system = with python3Packages; [
113+
cython_0
114+
setuptools
115+
];
116+
117+
dependencies = with python3Packages; [
118+
python3-eventlib
119+
python3-application
120+
# python3-sipsimple
121+
python3-otr
122+
pyqt6
123+
pyqt6.dev
124+
pyqt6-sip
125+
];
126+
127+
buildInputs = [
128+
# x11vnc
129+
libvncserver.dev
130+
];
131+
132+
meta = with lib; {
133+
homepage = "";
134+
description = "";
135+
license = licenses.bsd2;
136+
maintainers = with maintainers; [ ];
137+
mainProgram = "";
138+
};
139+
}

0 commit comments

Comments
 (0)