Skip to content

Commit 6d537c6

Browse files
committed
ci: add templates to check
1 parent df3e4d8 commit 6d537c6

File tree

2 files changed

+6
-0
lines changed

2 files changed

+6
-0
lines changed

default.nix

+4
Original file line numberDiff line numberDiff line change
@@ -117,6 +117,10 @@ rec {
117117

118118
project-models = import ./projects/models.nix { inherit lib pkgs sources; };
119119

120+
templates.project = project-models.project (
121+
import ./templates/project { inherit lib pkgs sources; }
122+
);
123+
120124
# TODO: find a better place for this
121125
metrics = with lib; {
122126
projects = attrNames raw-projects;

flake.nix

+2
Original file line numberDiff line numberDiff line change
@@ -212,6 +212,8 @@
212212
};
213213
"infra/makemake" = toplevel self.nixosConfigurations.makemake;
214214
"infra/overview" = self.packages.${system}.overview;
215+
# fake derivation for flake check
216+
"infra/templates" = pkgs.writeText "dummy" (lib.strings.toJSON classic'.templates.project);
215217
};
216218
in
217219
checksForInfrastructure // checksForAllProjects // checksForAllPackages;

0 commit comments

Comments
 (0)