Skip to content

Commit bde2830

Browse files
authored
Rosenpass: projects-old -> projects (#786)
1 parent a253db2 commit bde2830

File tree

14 files changed

+86
-16
lines changed

14 files changed

+86
-16
lines changed

projects-old/Rosenpass/default.nix

-16
This file was deleted.

projects/Rosenpass/default.nix

+55
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,55 @@
1+
{
2+
lib,
3+
pkgs,
4+
sources,
5+
}@args:
6+
7+
{
8+
metadata = {
9+
summary = "Rosenpass is a formally verified, post-quantum secure VPN that uses WireGuard to transport the actual data.";
10+
subgrants = [
11+
"Rosenpass"
12+
"Rosenpass-API"
13+
"Rosenpass-integration"
14+
];
15+
links = {
16+
docs = {
17+
text = "Rosenpass documentation";
18+
url = "https://rosenpass.eu/docs/";
19+
};
20+
docker = {
21+
text = "Rosenpass in Docker";
22+
url = "https://github.com/rosenpass/rosenpass/blob/main/docker/USAGE.md";
23+
};
24+
build = {
25+
text = "Build from source";
26+
url = "http://rosenpass.eu/docs/rosenpass-tool/compilation/#installation-via-binary-files";
27+
};
28+
};
29+
};
30+
31+
nixos.modules.programs = {
32+
rosenpass = {
33+
name = "rosenpass";
34+
module = ./programs/basic/module.nix;
35+
examples.basic = {
36+
module = ./programs/basic/examples/basic.nix;
37+
description = "";
38+
tests.basic = null;
39+
};
40+
};
41+
};
42+
43+
nixos.modules.services = {
44+
rosenpass = {
45+
name = "rosenpass";
46+
module = "${sources.inputs.nixpkgs}/nixos/modules/services/networking/rosenpass.nix";
47+
examples.basic = {
48+
module = ./services/basic/examples/basic.nix;
49+
description = "";
50+
tests.with-sops = import ./tests args;
51+
tests.without-sops = "${sources.inputs.nixpkgs}/nixos/tests/rosenpass.nix";
52+
};
53+
};
54+
};
55+
}
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,5 @@
1+
{ ... }:
2+
3+
{
4+
programs.rosenpass.enable = true;
5+
}
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,21 @@
1+
{
2+
config,
3+
lib,
4+
pkgs,
5+
...
6+
}:
7+
let
8+
cfg = config.programs.rosenpass;
9+
in
10+
{
11+
options.programs.rosenpass = {
12+
enable = lib.mkEnableOption "rosenpass";
13+
};
14+
15+
config = lib.mkIf cfg.enable {
16+
environment.systemPackages = with pkgs; [
17+
rosenpass
18+
rosenpass-tools
19+
];
20+
};
21+
}
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,5 @@
1+
{ ... }:
2+
3+
{
4+
services.rosenpass.enable = true;
5+
}

0 commit comments

Comments
 (0)