Skip to content

Commit a253db2

Browse files
committed
Pixelfed: projects-old -> projects
Closes #740
1 parent c9959b8 commit a253db2

File tree

3 files changed

+51
-13
lines changed

3 files changed

+51
-13
lines changed

projects-old/Pixelfed/default.nix

-13
This file was deleted.

projects/Pixelfed/default.nix

+34
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,34 @@
1+
{
2+
lib,
3+
pkgs,
4+
sources,
5+
}@args:
6+
7+
{
8+
metadata = {
9+
summary = "ActivityPub-driven decentralised photo sharing platform";
10+
subgrants = [
11+
"PixelDroid-MediaEditor"
12+
"PixelFedLive"
13+
"Pixelfed"
14+
"Pixelfed-Groups"
15+
];
16+
links = {
17+
docs = {
18+
text = "Documentation";
19+
url = "https://docs.pixelfed.org/";
20+
};
21+
};
22+
};
23+
24+
nixos.modules.services = {
25+
pixelfed = {
26+
module = "${sources.inputs.nixpkgs}/nixos/modules/services/web-apps/pixelfed.nix";
27+
examples.basic = {
28+
module = ./example.nix;
29+
description = "";
30+
tests.basic = "${sources.inputs.nixpkgs}/nixos/tests/web-apps/pixelfed/standard.nix";
31+
};
32+
};
33+
};
34+
}

projects/Pixelfed/example.nix

+17
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,17 @@
1+
{ pkgs, ... }:
2+
{
3+
services.pixelfed = {
4+
enable = true;
5+
domain = "pixelfed.local";
6+
7+
# Configure NGINX.
8+
nginx = { };
9+
secretFile = (
10+
pkgs.writeText "secrets.env" ''
11+
# Snakeoil secret, can be any random 32-chars secret via CSPRNG.
12+
APP_KEY=adKK9EcY8Hcj3PLU7rzG9rJ6KKTOtYfA
13+
''
14+
);
15+
settings."FORCE_HTTPS_URLS" = false;
16+
};
17+
}

0 commit comments

Comments
 (0)