Skip to content

Commit 6abb3f2

Browse files
overview: simplify per-project display
this also fixes local deployment by using relative links
1 parent 6d537c6 commit 6abb3f2

File tree

1 file changed

+10
-10
lines changed

1 file changed

+10
-10
lines changed

overview/default.nix

+10-10
Original file line numberDiff line numberDiff line change
@@ -100,9 +100,9 @@ let
100100
many =
101101
projectOptions:
102102
optionalString (!empty projectOptions) ''
103-
<section><details><summary>${heading 3 "Options"}</summary><dl>
103+
<details><summary>Options</summary><dl>
104104
${concatLines (map one projectOptions)}
105-
</dl></details></section>
105+
</dl></details>
106106
'';
107107
};
108108

@@ -121,9 +121,9 @@ let
121121
many =
122122
packages:
123123
optionalString (!empty packages) ''
124-
<section><details><summary>${heading 3 "Packages"}</summary><dl>
124+
<details><summary>Packages</summary><dl>
125125
${concatLines (map one packages)}
126-
</dl></details></section>
126+
</dl></details>
127127
'';
128128
};
129129

@@ -142,9 +142,9 @@ let
142142
many =
143143
examples:
144144
optionalString (!empty examples) ''
145-
<section><details><summary>${heading 3 "Examples"}</summary><ul>
145+
<details><summary>Examples</summary><ul>
146146
${concatLines (map one examples)}
147-
</ul></details></section>
147+
</ul></details>
148148
'';
149149
};
150150

@@ -176,7 +176,7 @@ let
176176
projects:
177177
concatLines (
178178
mapAttrsToList (name: _: ''
179-
<a href="/project/${name}">${name}</a>
179+
<a href="./project/${name}.html">${name}</a>
180180
'') projects
181181
);
182182
};
@@ -201,9 +201,9 @@ let
201201
}
202202
// mapAttrs' (
203203
name: project:
204-
nameValuePair "project/${name}/index.html" {
204+
nameValuePair "project/${name}.html" {
205205
pagetitle = "NGIpkgs | ${name}";
206-
html = pkgs.writeText "index.html" (render.projects.one name project);
206+
html = pkgs.writeText "${name}.html" (render.projects.one name project);
207207
}
208208
) projects;
209209

@@ -226,7 +226,7 @@ let
226226
--from=markdown+raw_html \
227227
--to=html \
228228
--standalone \
229-
--css="/style.css" \
229+
--css="./style.css" \
230230
--metadata-file=${metadata} \
231231
--output="$out/${path}" ${html}
232232

0 commit comments

Comments
 (0)