We read every piece of feedback, and take your input very seriously.
To see all available qualifiers, see our documentation.
1 parent 3c80c9c commit 3322e25Copy full SHA for 3322e25
flake.nix
@@ -105,10 +105,31 @@
105
[
106
config
107
{
108
+ imports = [
109
+ (nixpkgs + "/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix")
110
+ (nixpkgs + "/nixos/modules/virtualisation/qemu-vm.nix")
111
+ ];
112
+
113
+ virtualisation = {
114
+ memorySize = 4096;
115
116
+ qemu.options = [
117
+ "-cpu host"
118
+ "-enable-kvm"
119
120
121
+ forwardPorts = [
122
+ {
123
+ from = "host";
124
+ host.port = 2222;
125
+ guest.port = 22;
126
+ }
127
128
+ };
129
130
nixpkgs.hostPlatform = "x86_64-linux";
131
system.stateVersion = "23.05";
132
}
- (nixpkgs + "/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix")
133
]
134
# TODO: this needs to take a different shape,
135
# otherwise the transformation to obtain it is confusing
0 commit comments