We read every piece of feedback, and take your input very seriously.
To see all available qualifiers, see our documentation.
1 parent efeaf5e commit 3c80c9cCopy full SHA for 3c80c9c
flake.nix
@@ -101,14 +101,18 @@
101
mkNixosVM =
102
config:
103
nixosSystem {
104
- modules = [
105
- config
106
- {
107
- nixpkgs.hostPlatform = "x86_64-linux";
108
- system.stateVersion = "23.05";
109
- }
110
- (nixpkgs + "/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix")
111
- ];
+ modules =
+ [
+ config
+ {
+ nixpkgs.hostPlatform = "x86_64-linux";
+ system.stateVersion = "23.05";
+ }
+ (nixpkgs + "/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix")
112
+ ]
113
+ # TODO: this needs to take a different shape,
114
+ # otherwise the transformation to obtain it is confusing
115
+ ++ classic'.extendedNixosModules;
116
};
117
118
mkNixosAppVM = config: {
0 commit comments