Skip to content

Commit 3c80c9c

Browse files
committed
fix: add nixos modules
Let's not do this right now and keep it simple
1 parent efeaf5e commit 3c80c9c

File tree

1 file changed

+12
-8
lines changed

1 file changed

+12
-8
lines changed

flake.nix

+12-8
Original file line numberDiff line numberDiff line change
@@ -101,14 +101,18 @@
101101
mkNixosVM =
102102
config:
103103
nixosSystem {
104-
modules = [
105-
config
106-
{
107-
nixpkgs.hostPlatform = "x86_64-linux";
108-
system.stateVersion = "23.05";
109-
}
110-
(nixpkgs + "/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix")
111-
];
104+
modules =
105+
[
106+
config
107+
{
108+
nixpkgs.hostPlatform = "x86_64-linux";
109+
system.stateVersion = "23.05";
110+
}
111+
(nixpkgs + "/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix")
112+
]
113+
# TODO: this needs to take a different shape,
114+
# otherwise the transformation to obtain it is confusing
115+
++ classic'.extendedNixosModules;
112116
};
113117

114118
mkNixosAppVM = config: {

0 commit comments

Comments
 (0)