Skip to content

Commit bca3bbb

Browse files
abattersbyakuster
authored andcommitted
curlpp: fix QA Issue after LDFLAGS change
Adding -f*-prefix-map to LDFLAGS caused the following issue: QA Issue: curlpp.pc failed sanity test (tmpdir) Fix by filtering out -f*-prefix-map from *.pc files. [YOCTO #14481] Signed-off-by: Tony Battersby <[email protected]> Signed-off-by: Khem Raj <[email protected]> (cherry picked from commit c40e01b) Signed-off-by: Armin Kuster <[email protected]>
1 parent aaa1c12 commit bca3bbb

File tree

1 file changed

+7
-0
lines changed

1 file changed

+7
-0
lines changed

meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb

Lines changed: 7 additions & 0 deletions
Original file line numberDiff line numberDiff line change
@@ -16,3 +16,10 @@ S = "${WORKDIR}/git"
1616
inherit cmake pkgconfig binconfig
1717

1818
BBCLASSEXTEND = "native nativesdk"
19+
20+
do_install:append() {
21+
sed -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \
22+
-e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
23+
-e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
24+
-i ${D}${libdir}/pkgconfig/*.pc
25+
}

0 commit comments

Comments
 (0)