Skip to content

Commit 40425da

Browse files
committed
Add Blink package
Closes ngi-nix#605
1 parent 6d537c6 commit 40425da

File tree

1 file changed

+104
-0
lines changed

1 file changed

+104
-0
lines changed

pkgs/by-name/blink/package.nix

+104
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,104 @@
1+
{ lib
2+
, fetchFromGitHub
3+
4+
, python3Packages
5+
, x11vnc
6+
, libvncserver
7+
, pjsip
8+
}:
9+
10+
let
11+
python3-application = python3Packages.buildPythonApplication rec {
12+
pname = "python3-application";
13+
version = "3.0.7";
14+
pyproject = true;
15+
16+
src = fetchFromGitHub {
17+
owner = "AGProjects";
18+
repo = "python3-application";
19+
rev = "refs/tags/release-${version}";
20+
hash = "sha256-gGq1V+4GrjUgp6XteWAko4YRZuCWGArvImp8isUOoMU=";
21+
};
22+
23+
build-system = with python3Packages; [
24+
setuptools
25+
];
26+
27+
dependencies = with python3Packages; [
28+
zope-interface
29+
];
30+
};
31+
32+
python3-sipsimple = python3Packages.buildPythonApplication rec {
33+
pname = "python3-sipsimple";
34+
version = "5.3.3";
35+
pyproject = true;
36+
37+
src = fetchFromGitHub {
38+
owner = "AGProjects";
39+
repo = "python3-sipsimple";
40+
rev = "refs/tags/${version}";
41+
hash = "sha256-SiJo6YoYy4OiVVVKhfy0U1z4iz5aYPHu2P6JuJjXyEI=";
42+
};
43+
44+
build-system = with python3Packages; [
45+
cython_0
46+
setuptools
47+
];
48+
49+
dependencies = with python3Packages; [
50+
];
51+
52+
buildInputs = [
53+
pjsip
54+
];
55+
};
56+
57+
in
58+
python3Packages.buildPythonApplication rec {
59+
pname = "blink-qt";
60+
version = "6.0.4";
61+
pyproject = true;
62+
63+
src = fetchFromGitHub {
64+
owner = "AGProjects";
65+
repo = "blink-qt";
66+
rev = "refs/tags/${version}";
67+
hash = "sha256-QESg9yo5oddYqSKuFLSMI2Oju3FCq97+j0uJDK85Yy8=";
68+
};
69+
70+
# TODO: try to set language_level instead of using cython_0
71+
# postPatch = ''
72+
# substituteInPlace "setup.py" \
73+
# --replace-fail \
74+
# 'libraries=["vncclient"])]),' \
75+
# 'libraries=["vncclient"])], language_level = "2"),'
76+
# '';
77+
78+
build-system = with python3Packages; [
79+
cython_0
80+
setuptools
81+
];
82+
83+
dependencies = with python3Packages; [
84+
python3-eventlib
85+
python3-application
86+
python3-sipsimple
87+
pyqt6
88+
pyqt6.dev
89+
pyqt6-sip
90+
];
91+
92+
buildInputs = [
93+
# x11vnc
94+
libvncserver.dev
95+
];
96+
97+
meta = with lib; {
98+
homepage = "";
99+
description = "";
100+
license = licenses.bsd2;
101+
maintainers = with maintainers; [ ];
102+
mainProgram = "";
103+
};
104+
}

0 commit comments

Comments
 (0)