Skip to content

Commit 08bcdf1

Browse files
committed
Update chat/matrix-synapse to 1.22.0
Synapse 1.22.0 (2020-10-27) =========================== No significant changes. Synapse 1.22.0rc2 (2020-10-26) ============================== Bugfixes -------- - Fix bugs where ephemeral events were not sent to appservices. Broke in v1.22.0rc1. ([\#8648](matrix-org/synapse#8648), [\#8656](matrix-org/synapse#8656)) - Fix `user_daily_visits` table to not have duplicate rows per user/device due to multiple user agents. Broke in v1.22.0rc1. ([\#8654](matrix-org/synapse#8654)) Synapse 1.22.0rc1 (2020-10-22) ============================== Features -------- - Add a configuration option for always using the "userinfo endpoint" for OpenID Connect. This fixes support for some identity providers, e.g. GitLab. Contributed by Benjamin Koch. ([\#7658](matrix-org/synapse#7658)) - Add ability for `ThirdPartyEventRules` modules to query and manipulate whether a room is in the public rooms directory. ([\#8292](matrix-org/synapse#8292), [\#8467](matrix-org/synapse#8467)) - Add support for olm fallback keys ([MSC2732](matrix-org/matrix-spec-proposals#2732)). ([\#8312](matrix-org/synapse#8312), [\#8501](matrix-org/synapse#8501)) - Add support for running background tasks in a separate worker process. ([\#8369](matrix-org/synapse#8369), [\#8458](matrix-org/synapse#8458), [\#8489](matrix-org/synapse#8489), [\#8513](matrix-org/synapse#8513), [\#8544](matrix-org/synapse#8544), [\#8599](matrix-org/synapse#8599)) - Add support for device dehydration ([MSC2697](matrix-org/matrix-spec-proposals#2697)). ([\#8380](matrix-org/synapse#8380)) - Add support for [MSC2409](matrix-org/matrix-spec-proposals#2409), which allows sending typing, read receipts, and presence events to appservices. ([\#8437](matrix-org/synapse#8437), [\#8590](matrix-org/synapse#8590)) - Change default room version to "6", per [MSC2788](matrix-org/matrix-spec-proposals#2788). ([\#8461](matrix-org/synapse#8461)) - Add the ability to send non-membership events into a room via the `ModuleApi`. ([\#8479](matrix-org/synapse#8479)) - Increase default upload size limit from 10M to 50M. Contributed by @Akkowicz. ([\#8502](matrix-org/synapse#8502)) - Add support for modifying event content in `ThirdPartyRules` modules. ([\#8535](matrix-org/synapse#8535), [\#8564](matrix-org/synapse#8564)) Bugfixes -------- - Fix a longstanding bug where invalid ignored users in account data could break clients. ([\#8454](matrix-org/synapse#8454)) - Fix a bug where backfilling a room with an event that was missing the `redacts` field would break. ([\#8457](matrix-org/synapse#8457)) - Don't attempt to respond to some requests if the client has already disconnected. ([\#8465](matrix-org/synapse#8465)) - Fix message duplication if something goes wrong after persisting the event. ([\#8476](matrix-org/synapse#8476)) - Fix incremental sync returning an incorrect `prev_batch` token in timeline section, which when used to paginate returned events that were included in the incremental sync. Broken since v0.16.0. ([\#8486](matrix-org/synapse#8486)) - Expose the `uk.half-shot.msc2778.login.application_service` to clients from the login API. This feature was added in v1.21.0, but was not exposed as a potential login flow. ([\#8504](matrix-org/synapse#8504)) - Fix error code for `/profile/{userId}/displayname` to be `M_BAD_JSON`. ([\#8517](matrix-org/synapse#8517)) - Fix a bug introduced in v1.7.0 that could cause Synapse to insert values from non-state `m.room.retention` events into the `room_retention` database table. ([\#8527](matrix-org/synapse#8527)) - Fix not sending events over federation when using sharded event writers. ([\#8536](matrix-org/synapse#8536)) - Fix a long standing bug where email notifications for encrypted messages were blank. ([\#8545](matrix-org/synapse#8545)) - Fix increase in the number of `There was no active span...` errors logged when using OpenTracing. ([\#8567](matrix-org/synapse#8567)) - Fix a bug that prevented errors encountered during execution of the `synapse_port_db` from being correctly printed. ([\#8585](matrix-org/synapse#8585)) - Fix appservice transactions to only include a maximum of 100 persistent and 100 ephemeral events. ([\#8606](matrix-org/synapse#8606)) Updates to the Docker image --------------------------- - Added multi-arch support (arm64,arm/v7) for the docker images. Contributed by @maquis196. ([\#7921](matrix-org/synapse#7921)) - Add support for passing commandline args to the synapse process. Contributed by @samuel-p. ([\#8390](matrix-org/synapse#8390)) Improved Documentation ---------------------- - Update the directions for using the manhole with coroutines. ([\#8462](matrix-org/synapse#8462)) - Improve readme by adding new shield.io badges. ([\#8493](matrix-org/synapse#8493)) - Added note about docker in manhole.md regarding which ip address to bind to. Contributed by @maquis196. ([\#8526](matrix-org/synapse#8526)) - Document the new behaviour of the `allowed_lifetime_min` and `allowed_lifetime_max` settings in the room retention configuration. ([\#8529](matrix-org/synapse#8529)) Deprecations and Removals ------------------------- - Drop unused `device_max_stream_id` table. ([\#8589](matrix-org/synapse#8589)) Internal Changes ---------------- - Check for unreachable code with mypy. ([\#8432](matrix-org/synapse#8432)) - Add unit test for event persister sharding. ([\#8433](matrix-org/synapse#8433)) - Allow events to be sent to clients sooner when using sharded event persisters. ([\#8439](matrix-org/synapse#8439), [\#8488](matrix-org/synapse#8488), [\#8496](matrix-org/synapse#8496), [\#8499](matrix-org/synapse#8499)) - Configure `public_baseurl` when using demo scripts. ([\#8443](matrix-org/synapse#8443)) - Add SQL logging on queries that happen during startup. ([\#8448](matrix-org/synapse#8448)) - Speed up unit tests when using PostgreSQL. ([\#8450](matrix-org/synapse#8450)) - Remove redundant database loads of stream_ordering for events we already have. ([\#8452](matrix-org/synapse#8452)) - Reduce inconsistencies between codepaths for membership and non-membership events. ([\#8463](matrix-org/synapse#8463)) - Combine `SpamCheckerApi` with the more generic `ModuleApi`. ([\#8464](matrix-org/synapse#8464)) - Additional testing for `ThirdPartyEventRules`. ([\#8468](matrix-org/synapse#8468)) - Add `-d` option to `./scripts-dev/lint.sh` to lint files that have changed since the last git commit. ([\#8472](matrix-org/synapse#8472)) - Unblacklist some sytests. ([\#8474](matrix-org/synapse#8474)) - Include the log level in the phone home stats. ([\#8477](matrix-org/synapse#8477)) - Remove outdated sphinx documentation, scripts and configuration. ([\#8480](matrix-org/synapse#8480)) - Clarify error message when plugin config parsers raise an error. ([\#8492](matrix-org/synapse#8492)) - Remove the deprecated `Handlers` object. ([\#8494](matrix-org/synapse#8494)) - Fix a threadsafety bug in unit tests. ([\#8497](matrix-org/synapse#8497)) - Add user agent to user_daily_visits table. ([\#8503](matrix-org/synapse#8503)) - Add type hints to various parts of the code base. ([\#8407](matrix-org/synapse#8407), [\#8505](matrix-org/synapse#8505), [\#8507](matrix-org/synapse#8507), [\#8547](matrix-org/synapse#8547), [\#8562](matrix-org/synapse#8562), [\#8609](matrix-org/synapse#8609)) - Remove unused code from the test framework. ([\#8514](matrix-org/synapse#8514)) - Apply some internal fixes to the `HomeServer` class to make its code more idiomatic and statically-verifiable. ([\#8515](matrix-org/synapse#8515)) - Factor out common code between `RoomMemberHandler._locally_reject_invite` and `EventCreationHandler.create_event`. ([\#8537](matrix-org/synapse#8537)) - Improve database performance by executing more queries without starting transactions. ([\#8542](matrix-org/synapse#8542)) - Rename `Cache` to `DeferredCache`, to better reflect its purpose. ([\#8548](matrix-org/synapse#8548)) - Move metric registration code down into `LruCache`. ([\#8561](matrix-org/synapse#8561), [\#8591](matrix-org/synapse#8591)) - Replace `DeferredCache` with the lighter-weight `LruCache` where possible. ([\#8563](matrix-org/synapse#8563)) - Add virtualenv-generated folders to `.gitignore`. ([\#8566](matrix-org/synapse#8566)) - Add `get_immediate` method to `DeferredCache`. ([\#8568](matrix-org/synapse#8568)) - Fix mypy not properly checking across the codebase, additionally, fix a typing assertion error in `handlers/auth.py`. ([\#8569](matrix-org/synapse#8569)) - Fix `synmark` benchmark runner. ([\#8571](matrix-org/synapse#8571)) - Modify `DeferredCache.get()` to return `Deferred`s instead of `ObservableDeferred`s. ([\#8572](matrix-org/synapse#8572)) - Adjust a protocol-type definition to fit `sqlite3` assertions. ([\#8577](matrix-org/synapse#8577)) - Support macOS on the `synmark` benchmark runner. ([\#8578](matrix-org/synapse#8578)) - Update `mypy` static type checker to 0.790. ([\#8583](matrix-org/synapse#8583), [\#8600](matrix-org/synapse#8600)) - Re-organize the structured logging code to separate the TCP transport handling from the JSON formatting. ([\#8587](matrix-org/synapse#8587)) - Remove extraneous unittest logging decorators from unit tests. ([\#8592](matrix-org/synapse#8592)) - Minor optimisations in caching code. ([\#8593](matrix-org/synapse#8593), [\#8594](matrix-org/synapse#8594))
1 parent c685aa9 commit 08bcdf1

File tree

3 files changed

+25
-9
lines changed

3 files changed

+25
-9
lines changed

chat/matrix-synapse/Makefile

+2-3
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,6 @@
1-
# $NetBSD: Makefile,v 1.10 2020/10/17 13:57:50 js Exp $
1+
# $NetBSD: Makefile,v 1.11 2020/10/27 21:52:35 js Exp $
22

3-
DISTNAME= matrix-synapse-1.21.2
4-
PKGREVISION= 1
3+
DISTNAME= matrix-synapse-1.22.0
54
CATEGORIES= chat
65
MASTER_SITES= ${MASTER_SITE_GITHUB:=matrix-org/}
76
EGG_NAME= matrix_synapse-${PKGVERSION_NOREV}

chat/matrix-synapse/PLIST

+18-1
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
1-
@comment $NetBSD: PLIST,v 1.3 2020/10/17 11:42:35 js Exp $
1+
@comment $NetBSD: PLIST,v 1.4 2020/10/27 21:52:35 js Exp $
22
bin/export_signing_key
33
bin/generate_config
44
bin/generate_log_config
@@ -90,6 +90,9 @@ ${PYSITELIB}/synapse/app/homeserver.pyo
9090
${PYSITELIB}/synapse/app/media_repository.py
9191
${PYSITELIB}/synapse/app/media_repository.pyc
9292
${PYSITELIB}/synapse/app/media_repository.pyo
93+
${PYSITELIB}/synapse/app/phone_stats_home.py
94+
${PYSITELIB}/synapse/app/phone_stats_home.pyc
95+
${PYSITELIB}/synapse/app/phone_stats_home.pyo
9396
${PYSITELIB}/synapse/app/pusher.py
9497
${PYSITELIB}/synapse/app/pusher.pyc
9598
${PYSITELIB}/synapse/app/pusher.pyo
@@ -496,6 +499,9 @@ ${PYSITELIB}/synapse/http/site.pyo
496499
${PYSITELIB}/synapse/logging/__init__.py
497500
${PYSITELIB}/synapse/logging/__init__.pyc
498501
${PYSITELIB}/synapse/logging/__init__.pyo
502+
${PYSITELIB}/synapse/logging/_remote.py
503+
${PYSITELIB}/synapse/logging/_remote.pyc
504+
${PYSITELIB}/synapse/logging/_remote.pyo
499505
${PYSITELIB}/synapse/logging/_structured.py
500506
${PYSITELIB}/synapse/logging/_structured.pyc
501507
${PYSITELIB}/synapse/logging/_structured.pyo
@@ -1394,6 +1400,8 @@ ${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/09shadow_ban.sql
13941400
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/10_pushrules_enabled_delete_obsolete.sql
13951401
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/10drop_local_rejections_stream.sql
13961402
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/10federation_pos_instance_name.sql
1403+
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/11dehydration.sql
1404+
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/11fallback.sql
13971405
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/11user_id_seq.py
13981406
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/11user_id_seq.pyc
13991407
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/11user_id_seq.pyo
@@ -1406,6 +1414,12 @@ ${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/15unread_count.sql
14061414
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/16populate_stats_process_rooms_fix.sql
14071415
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/17_catchup_last_successful.sql
14081416
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/18stream_positions.sql
1417+
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/19instance_map.sql.postgres
1418+
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/19txn_id.sql
1419+
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/20instance_name_event_tables.sql
1420+
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/20user_daily_visits.sql
1421+
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/21as_device_stream.sql
1422+
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/21drop_device_max_stream_id.sql
14091423
${PYSITELIB}/synapse/storage/databases/main/schema/full_schemas/16/application_services.sql
14101424
${PYSITELIB}/synapse/storage/databases/main/schema/full_schemas/16/event_edges.sql
14111425
${PYSITELIB}/synapse/storage/databases/main/schema/full_schemas/16/event_signatures.sql
@@ -1552,6 +1566,9 @@ ${PYSITELIB}/synapse/util/async_helpers.pyo
15521566
${PYSITELIB}/synapse/util/caches/__init__.py
15531567
${PYSITELIB}/synapse/util/caches/__init__.pyc
15541568
${PYSITELIB}/synapse/util/caches/__init__.pyo
1569+
${PYSITELIB}/synapse/util/caches/deferred_cache.py
1570+
${PYSITELIB}/synapse/util/caches/deferred_cache.pyc
1571+
${PYSITELIB}/synapse/util/caches/deferred_cache.pyo
15551572
${PYSITELIB}/synapse/util/caches/descriptors.py
15561573
${PYSITELIB}/synapse/util/caches/descriptors.pyc
15571574
${PYSITELIB}/synapse/util/caches/descriptors.pyo

chat/matrix-synapse/distinfo

+5-5
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
1-
$NetBSD: distinfo,v 1.6 2020/10/17 11:42:35 js Exp $
1+
$NetBSD: distinfo,v 1.7 2020/10/27 21:52:35 js Exp $
22

3-
SHA1 (matrix-synapse-1.21.2.tar.gz) = ff7321bec10acf5f59534535f077fdc88601e3f7
4-
RMD160 (matrix-synapse-1.21.2.tar.gz) = d1a479ab67c748e14f04f3834db2ff27b88ef5fb
5-
SHA512 (matrix-synapse-1.21.2.tar.gz) = 745ea382e38fa427e062fdab595c45b350bdd8002af252f38dff3e5b0bbee50230ff10bdf9e39fc97071c96340f89a7a994ab2238aaa16da65b145c1e144edaa
6-
Size (matrix-synapse-1.21.2.tar.gz) = 6930190 bytes
3+
SHA1 (matrix-synapse-1.22.0.tar.gz) = 8816101f15a1d4a4476791e07411af39a33d5fb3
4+
RMD160 (matrix-synapse-1.22.0.tar.gz) = 15b18e260e13f7bbab455af47675736550cbc03f
5+
SHA512 (matrix-synapse-1.22.0.tar.gz) = 0d037732fba5314c981c3d16e0858e3ea526a5b9aa7f60abb4fd3ed8c32755db2dc502119a6a8bc70e58b2a28c807ed3596ce5bbdce8260ca469d6b1e11faf3a
6+
Size (matrix-synapse-1.22.0.tar.gz) = 6961215 bytes

0 commit comments

Comments
 (0)